[RESOLVED] Pandas - "Installed openpyxl is not supported at this time" (version warning)

(Updated October 9, 2014)

.../site-packages/pandas/io/excel.py:626:
UserWarning: Installed openpyxl is not supported at this time. Use >=1.6.1 and <2.0.0.

This is only a warning, which can be ignored unless you are using openpyxl to read spreadsheets in pandas.

This warning no longer appears in Pandas 0.14.1 and above, now available in the Canopy Package Manager and via the "enpkg" command-line utility.

Canopy subscribers only: Note that if you are actually using openpyxl to read spreadsheets in pandas, then due to continuing limitations in pandas, you must downgrade openpyxl as follows: 

1) Be sure that you are already logged in to Canopy (check the Welcome Screen).

2) Open the Canopy Command Prompt or Canopy Terminal from the Canopy Tools menu, and type the following commands at the command prompt:

enpkg openpyxl 1.8.5

Reference: What's New in Pandas 0.14.1 (July 11, 2014) -- API changes 

Have more questions? Submit a request

Comments

  • Avatar
    zhensong qian

    Nice, fixed the warning.

  • Avatar
    Mark Ringrose

    Worked for me too.  I changed the pandas package using the handy Package Manager that is part of Enthought Canopy.  Thank you for the post.

  • Avatar
    bob kuhfahl

    Just installed canopy 1.4.1 and using pandas read_csv was not working,  Could not get the above command to work, nor figure out how to do the backlevel manually.  Then I broke down and used the gui package manger to update the "free" packages.

    read_csv now works.

  • Avatar
    Jonathan March

    Thanks for the feedback, @bob. Updated article to clarify that the enpkg openpyxl command only applies to Canopy subscribers.

Powered by Zendesk