"Warning: failed to load some plugins" after update to Canopy 1.4.0

(updated June 26, 2014)

Symptom:

Popup "Warning: failed to load some plugins" when starting Canopy 1.4.0 (after an update from an earlier version).

Solution:

Our apologies for the noise. It does not reflect any actual problem, and can be safely ignored. It has been suppressed in Canopy 1.4.1 and higher.

Or, if you wish to prevent the warning from recurring without updating (Canopy add-on users, first please see caution below):

1) Quit the Canopy GUI application.

2) Delete the Canopy System directory. By default, it is located in the following location, depending on your platform:

 Platform

Word length
  Location
Windows XP  64 C:\Documents and Settings\<username>\Local Settings\Application Data\Enthought\Canopy\System
Windows XP 32 C:\Documents and Settings\<username>\Local Settings\Application Data\Enthought\Canopy32\System
Windows 7,8 & Vista 64 C:\Users\<username>\AppData\Local\Enthought\Canopy\System
Windows 7,8 & Vista 32 C:\Users\<username>\AppData\Local\Enthought\Canopy32\System
Mac OSX 64 ~/Library/Enthought/Canopy_64bit/System
Mac OSX 32 ~/Library/Enthought/Canopy_32bit/System
Linux 64 ~/Enthought/Canopy_64bit/System
Linux 32 ~/Enthought/Canopy_32bit/System

3) Restart Canopy. The System directory will automatically be re-created and Canopy should start without the warning message.

Caution: if you are a user of the geocanopy add-on, or another Canopy add-on package, deleting the entire System directory would also delete that add-on, which would then need to be re-installed. In that case, you might prefer to delete only the following file within the System directory: "addons/CanopyTraining_addon-0.9.902-1.egg".

 

 

 

 

 

Have more questions? Submit a request

Comments

Powered by Zendesk