I have a subscription but I cannot...

Problem:

You have a current (typically new or just-renewed) Canopy subscription but still one or more of the following occurs:

Solutions:

1. (Typical scenario): Log out (of the Canopy Welcome Screen, or the Enthought store website, or the training site [https://training.enthought.com/], respectively), then log back in. 

Or, for the Package Manager and debugger access issues in Canopy, simply quit and restart Canopy (assuming that you are already logged in).

For the Package Manager subscription problem, starting in Canopy 1.5.4, it will usually be sufficient to quit and restart the Package Manager

Reason: The Canopy application only checks your subscription status when you start it, and/or when you log in on the Canopy Welcome Screen, and/or (starting in 1.5.4) when you restart the Package Manager.

The training web site (https://training.enthought.com/) only checks your subscription status when you log in to it. (It is separate from the Enthought store website.)

2. (For some institutional users): You are running behind a proxy firewall (whether you realize it or not) and need to explicitly configure Canopy to work with the proxy. See this article: Can I use Canopy Behind a Proxy Firewall?

Even if you can already access the Enthought web site in your browser, you will still need to configure Canopy explicitly for the proxy.

 

Please do not enter support requests in article comments

Please use article comments for suggestions to improve the article. For individual support requests, please follow these guidelines.

Have more questions? Submit a request

Comments

  • Avatar
    TT Sun

    Hi, I just installed 1.5.2.2785 on win7. But when I tried to log in from the welcome page, it says "Unable to connect to the authenticate your login. Please check internet connection (or proxy concfig...)". But I am sure my internet connection works fine and I can log in on the enthough website with my login details. Any idea?

    Also on another related issue, on another win8 machine, I can log in fine but I can't see the enable debugger option after log in; did try to close and restart canopy but still the same problem without seeing enable debugger option on the welcome page. 

  • Avatar
    TT Sun

    Sorry just to give a bit more information about the problem about logging in on the welcome page. I am using canopy through a company machine and the error I got when testing the detailed network access is :

    Method: urllib2

    Checking http://www.enthought.com/

    Failed

    URLError(gaierror(11004, 'getaddrinfo failed'),)

    {'reason': gaierror(11004, 'getaddrinfo failed')}

    Checking https://www.enthought.com/

    Failed

    URLError(gaierror(11004, 'getaddrinfo failed'),)

    {'reason': gaierror(11004, 'getaddrinfo failed')}

    Checking https://api.enthought.com/

    Failed

    URLError(gaierror(11004, 'getaddrinfo failed'),)

    {'reason': gaierror(11004, 'getaddrinfo failed')}

    Checking https://grits.enthought.com/

    Failed

    URLError(gaierror(11004, 'getaddrinfo failed'),)

    {'reason': gaierror(11004, 'getaddrinfo failed')}

    Checking https://training.enthought.com/

    Failed

    URLError(gaierror(11004, 'getaddrinfo failed'),)

    {'reason': gaierror(11004, 'getaddrinfo failed')}

    Checking https://storage-cf.enthought.com/www/canopy/etod-has-access.png

    Failed

    Expected failure: ssl in python <= 2.7.8 does not support TLS SNI extension

    URLError(gaierror(11004, 'getaddrinfo failed'),)

    {'reason': gaierror(11004, 'getaddrinfo failed')}

    Method: requests

    Checking http://www.enthought.com/

    Failed

    ConnectionError(ProtocolError('Connection aborted.', gaierror(11004, 'getaddrinfo failed')),)

    {'request': <PreparedRequest [GET]>, 'response': None}

    Checking https://www.enthought.com/

    Failed

    ConnectionError(ProtocolError('Connection aborted.', gaierror(11004, 'getaddrinfo failed')),)

    {'request': <PreparedRequest [GET]>, 'response': None}

    Checking https://api.enthought.com/

    Failed

    ConnectionError(ProtocolError('Connection aborted.', gaierror(11004, 'getaddrinfo failed')),)

    {'request': <PreparedRequest [GET]>, 'response': None}

    Checking https://grits.enthought.com/

    Failed

    ConnectionError(ProtocolError('Connection aborted.', gaierror(11004, 'getaddrinfo failed')),)

    {'request': <PreparedRequest [GET]>, 'response': None}

    Checking https://training.enthought.com/

    Failed

    ConnectionError(ProtocolError('Connection aborted.', gaierror(11004, 'getaddrinfo failed')),)

    {'request': <PreparedRequest [GET]>, 'response': None}

    Checking https://storage-cf.enthought.com/www/canopy/etod-has-access.png

    Failed

    ConnectionError(ProtocolError('Connection aborted.', gaierror(11004, 'getaddrinfo failed')),)

    {'request': <PreparedRequest [GET]>, 'response': None}

    Method: qt

    Checking http://www.enthought.com/

    Failed

    PySide.QtNetwork.QNetworkReply.NetworkError.HostNotFoundError

    Host www.enthought.com not found

    Checking https://www.enthought.com/

    Failed

    PySide.QtNetwork.QNetworkReply.NetworkError.HostNotFoundError

    Host not found

    Checking https://api.enthought.com/

    Failed

    PySide.QtNetwork.QNetworkReply.NetworkError.HostNotFoundError

    Host not found

    Checking https://grits.enthought.com/

    Failed

    PySide.QtNetwork.QNetworkReply.NetworkError.HostNotFoundError

    Host not found

    Checking https://training.enthought.com/

    Failed

    PySide.QtNetwork.QNetworkReply.NetworkError.HostNotFoundError

    Host not found

    Checking https://storage-cf.enthought.com/www/canopy/etod-has-access.png

    Failed

    Expected failure: ssl linked with Qt does not support TLS SNI extension

    PySide.QtNetwork.QNetworkReply.NetworkError.HostNotFoundError

    Host not found

     

     

  • Avatar
    John Lutz

    Was there ever an answer to this? I'm having the same problem...

  • Avatar
    Jonathan March

    TT and John, apologies for the delay in responding. (These articles are on a new system and we have not been getting notifications as expected.) By far the most likely cause of this problem is that your machines are behind a proxy firewall. I'll add a paragraph with a link in the article in a few minutes.

  • Avatar
    instagram likes
Powered by Zendesk