Immediate end of support for 3-year-old Python package installers

On Wednesday, 23 August 2017, we will give Enthought's website a major upgrade, which affects our package repositories.

Consequently, versions of our legacy package installer (enstaller / enpkg) that are more than 3 years old will no longer be able to access these repositories.

Canopy 1.4.1 and earlier

In Canopy 1.4.1 (June 2014) and earlier versions, both the Package Manager, and enpkg in a Canopy Command Prompt/Terminal, will stop working. To install the current version of Canopy, please see "Installing a new Canopy version" in the support Knowledge Base.

Enthought Python Distribution (EPD) 7.3-2 and earlier

In EPD version 7.3-2 (July 2012), and earlier versions, the originally installed version of enstaller will stop working. You can check the version of your current enstaller by typing:

enpkg --version

If this shows an enstaller version less than 4.7, please install the latest version of enstaller. See "Installation" in enstaller's github repository.
 

Difficulties?

If you have any difficulties installing the newer version of Canopy or enstaller, please email support@enthought.com. (Please use article comments only for suggestions to improve the article.)

Have more questions? Submit a request

Comments

Powered by Zendesk