Canopy v2 - Updating the Python runtime version

Canopy version 2 gives you the ability to update the Python "runtime" (interpreter and standard libraries) in-place, i.e. without needing to re-install any packages. This is possible as long as the Python "Major.minor" version (e.g. "2.7" or "3.5") has not changed; in this case, your installed packages will continue to work on the updated Python.

The following steps will upgrade the Python in your Canopy User environment, to the latest available compatible version:

  1. Start a Canopy command prompt/terminal from the Canopy Tools menu.
  2. Close all other Canopy windows/applications including the Welcome screen.
  3. Run the following command at the command prompt/terminal from step 1:
    edm envs upgrade User
  4. Restart Canopy. It will now be using the latest available compatible Python runtime.
Have more questions? Submit a request

Comments

Powered by Zendesk