When re-installing Canopy 2: Replace, or Use existing Python environment?

 

Screen_Shot_2017-05-05_at_3.47.13_PM.png

 

Reasons to replace:

  • You haven't customized your existing Python environment much (or you've customized it too much, and it's not working as you want!), and you'd be happy to start over with a clean set of packages.
  • You have a slow internet connection, or are disconnected from the internet, and you want to get the latest available versions of all the Enthought packages, all installed at once from the Canopy full installer (available to subscribers only).

Reasons not to replace:

  • You've already installed Canopy for Python 2.7 and now you want to install it for Python 3.5. No need to get rid of your old environment! Instead, open the Canopy Preferences dialog and create a new environment for Python 3.5.
  • You want the latest / greatest Canopy features. Never fear -- your Canopy application has already been updated. This question is just about the Python environment which will run your code.

 

Please do not enter support requests in article comments

Please use article comments for suggestions to improve the article. For individual support requests, please follow these guidelines.

Have more questions? Submit a request

Comments

Powered by Zendesk