Knowledge Base/Canopy/Introduction to Canopy

Canopy is a new install, not an in-place update of EPD

Jonathan March
posted this on April 17, 2013 10:50

(Updated September 10, 2013)

EPD 7.3 (or earlier) and Canopy are completely independent Python distributions. Canopy is the next-generation EPD, plus a GUI application. It requires a new install.

If you want, you can continue to use EPD 7.x until you are are comfortable with switching completely to Canopy Python, but you cannot upgrade EPD 7.x to Canopy, in place. 

The only way that Canopy and EPD impinge on each other, as any two Python distributions necessarily do when installed simultaneously, is that at any given time, of course only one of them can be your your default "python" in a terminal shell (bash or cmd). When you install Canopy, you can choose whether you want Canopy to become your default python. You can also switch this back and forth by modifying your PATH.

Do not attempt to share packages between two separate Python distributions, e.g. between EPD and Canopy. The risk is too high of unpredictable interactions and difficult-to-trace failure. To use the same third-party packages in Canopy that you have added to EPD, install those packages within Canopy Python. (In contrast, it is generally safe to set the PYTHONPATH environment variable to point to individual modules which have not actually been installed into either Python distribution -- typically your own work in progress.

The Canopy / EPD online package repository

 If you have both Canopy and EPD 7.x installed, they both have update access to the same online package repository, using the same user login credentials, but the packages are installed separately into EPD and into Canopy (for example, EPD and Canopy could have different versions of the same package if you so chose.)

You can continue to update the packages in EPD 7.x using "enpkg" as before. Canopy is designed to update packages using its GUI Package Manager, but it can also use "enpkg" to update its packages when the PATH is set appropriately.

For reference, the Canopy / EPD package repository is located here: https://www.enthought.com/repo/epd/ (Subscriber sign in required, see upper right of screen). The path to the repo through the new website is: Products / EPD / EPD Package Index / Login to repo (orange button). Users will typically only need to manually access this repository if for some reason (proxy, firewall) they are unable to update packages in the usual way, through Canopy's Package Manager, or the "enpkg" update utility in Canopy and EPD. If you do download an egg manually, install it with "egginst <egg-file-name>".