Knowledge Base/Specific Canopy/EPD Packages


Jonathan March
posted this on December 11, 2012 16:00

(Updated January 9, 2014 )

EPD 7.x and most versions of Canopy ship with wxPython 2.8, not 2.9, because of numerous compatibility issues with 2.9. We expect these compatibility issues to be resolved in 2014.

Since wxPython 2.8 does not work at all on 64-bit EPD for OS X, this "computational" version of EPD ships without any version of wxPython.

For now, wxPython 2.9 for Mac OS X (32- or 64-bit) can be downloaded from the EPD repository by registered Enthought users, and used as bleeding-edge, experimental software. It is also included in 64-bit Canopy for OS X.

We recommend that users who do not have a large wx-specific code base use the Qt backend rather than wx. This can be done using either Pyside or PyQt interface package, both available to EPD subscribers. (PyQt is not available for OS X 64-bit.)

Canopy: Import error on Linux, fixed in Canopy 1.0.3

On newer linuxes (Ubuntu 12:04, Fedora 18), import wx fails in Canopy due to compatibility problems with glib bundled with Canopy (as a Qt dependency for RH5) and the system gtk used by wx.  This is a known issue with the Canopy Linux beta installers and was  fixed in a Canopy 1.0.3.

Ubuntu 13.10 - Import error

ImportError: /usr/lib/x86_64-linux-gnu/ undefined symbol: g_type_class_adjust_private_offset

We do not expect an immediate solution for this problem.



User photo
Adam Carreon


I am curious to know if the Ubuntu 13.10+ - Import Error has received a solution yet?

My Import Error is slightly different but the source is the same I believe:

ImportError: Matplotlib backend_wx and backend_wxagg require wxPython >=2.8

I know my code works properly on Windows, MacOS, and older versions of Ubuntu so I am assuming that trying to fix my problem through my code would not be the most beneficial. Also, there is a lot of wx references in my code soI would like to avoid switching backends. Thanks for your help! Have a great day!

January 09, 2014 14:16
User photo
Jonathan March

@Adam, sorry, we do not expect to support wx 2.8 on Ubuntu 13.10+ in the near future, due to ABI incompatibilities. I have updated the article to reflect this, also the fact that we have not yet worked on wx 2.9 compatibility issues because Qt is a much higher priority for an every-increasing proportion of our users.

January 09, 2014 19:58
User photo
Jean de la Croix Ki

Hi, I'm using canopy 1.3.0 (64bits) on fedora 20, and when I import wxPython using import wx I got this error : 

Traceback (most recent call last):
File "", line 8, in <module>
import wx
File "/home/jea/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/wx/", line 45, in <module>
from wx._core import *
File "/home/jea/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/wx/", line 4, in <module>
import _core_
ImportError: /lib64/ undefined symbol: g_type_class_adjust_private_offset


How can I fix this? Thanks

March 20, 2014 06:14
User photo
Marc-Antoine Drouin


I'm using canopy 1.3.0 (64 bit) on a fedora 20.I also had the error: ImportError: Matplotlib backend_wx and backend_wxagg require wxPython >=2.8

It seems I managed to fix the problem by commenting the line "backend      : WXAgg" in the file Enthought/Canopy_64bit/User/lib/python2.7/site-packages/matplotlib/mpl-data/matplotlibrc


March 31, 2014 08:35